Skip to main content
 

So, attempted to upgrade my server from Ubuntu 14.10 to 16.10. Everything seemingly went smoothly, except mysql. For some reason it didn't get upgraded. No big deal, I thought to myself, I'll just install it. Well, it turns out there's some sort of problem with mysql and Ubuntu 16.10. I Google'd and I Google'd, tried a bunch of different suggestions, nothing worked, mysql just wouldn't properly install.


I'm now in the process of upgrading to Ubuntu 17.04. I looked through the release notes for 17.04 and there's no mention of any issues with mysql, so hopefully this will solve my problem. When there's no way back, you go through.


My first attempt to upgrade to 17.04 didn't go very well. The broken mysql-server packages from 16.10 were still in place and caused the upgrade to fail. That was a treat to troubleshoot and smooth out. I've got it going now though.


On a related note, because my server is down, I can't post this update, so I'm writing it down now and I'll attempt to post it with a "published date" in the past and see if Known accepts it.